ひびのログ

日々ではないけどログを出力していくブログ

npm

Mac で npm の canvas をインストールするときにハマった話

古いバージョンの canvas モジュールのインストール時に node-gyp もインストールされるが、エラーが発生してインストールできなかった。 環境 macOS Hight Sierra ( version 10.13.6 ) やりたかったこと npm install canvas@1.x.x TL;DR brew install pkg-c…

【未解決】Nuxt.js を 2 にアップグレードしたかったけど断念した話

だめだったやり方 前準備 参考:Release v2.0.0 · nuxt/nuxt.js · GitHub まずは .nuxt node_modules yarn.lock package.lock.json を削除 node >= 10、npm >= 5 が推奨なので、それぞれアップデート。 nodist を利用しているので、 $ nodist 10.15.1 10.15.…

npm パッケージ作成奮闘録 ~Browserify を添えて~

先日作成した npm パッケージについて、所感等まとめておこうと思います。 npm パッケージ作りました 詳しくはこちらの Qiita のページを参照してください。 qiita.com 内容としては、「insertAdjacentHTML」を使いやすくしよう! ということで作成しました…